Sorry, you need to enable JavaScript to visit this website.

IT Security Announcement - Internet Explorer

The US Department of Homeland Security is advising Americans not to use Internet Explorer until a fix is found for a serious security flaw that came to light over the weekend.
Microsoft has confirmed that a security issue with its web browser Internet Explorer makes it vulnerable to hackers. Explorer versions 6 through 11 are vulnerable. Internet Explorer vulnerabilities could corrupt memory or allow a hacker to execute code. The bug gains access to computers when users click on a fake and malicious website.
 
IT department strongly recommends users to use alternate browsers until this issue is resolved.
 
Please contact the IT Service Desk at 215.646.7300 ext. 21444 or email it@gmercyu.edu if you have questions or comments.